Sign up ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

I am installing 12c Grid Control agent on my server via Enterprise manager.

The targer server is a UNIX server with AIX OS on it. I add target host manually, enter authentication information, host name, installation directory, etc. and all goes well untill I click "Deploy Agent" button, then I get the following error:

"Shell path is incorrect or not defined.:/bin/bash(SH_PATH),-c(SH_ARGS) on host MyHostName"

and details are :

"Check the property values in the following files in this order, or or, in "/u02/app/oracle/middleware/oms/oui/prov/resources"

There isn't /u02/app" directory on my target server, only /u01/app/oracle" so I assume the above directory is on the same server as Enterprise manager.

Although I did find a directory where I have files of the format - /u01/app/oracle/product/

Since my platform ia AIX, I used file

On my target server if I run which bash I get /usr/bin/bash and which ssh returns /usr/bin/ssh ahd which sh returns /usr/bin/sh

So I edited the file so that SH_PATH=/usr/bin/sh but still getting the same error. I have also tried setting to SH_PATH=/usr/bin/bash but nothing seems to make any difference. I am thinking one possibility would be I am editing wrong file.

Can anyone help?

share|improve this question

migrated from Feb 2 '13 at 10:51

This question came from our site for professional and enthusiast programmers.

If you've got root access, symbolic link your bash binary so there's a link at /bin/bash – Phil Feb 2 '13 at 11:49

2 Answers 2

I'm currently working on the same problem. I'm still in the process of doing this. What I can tell you, is, that not /usr/bin/sh fails but OMS can not establish the ssh session . Please check this in the log file. After I logged in with my AD-Account, the deployment started to work, but lastly failed because the AD-Account has not enough permissions to get it finished.


share|improve this answer

try the following doc EM 12c Agent Push Fails With Shell Path is Incorrect or Not Defined : /bin/bash(SH_PATH),-c(SH_ARGS) (Doc ID 1489437.1)

share|improve this answer
Please tell us the contents of that document. – Colin 't Hart Aug 12 '14 at 13:10

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.