Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

I have setup SSRS on SQL Server 2008 in native mode.

As an administrator I can login to report manager, upload reports and run them, and also use the Web Service URL to generate reports.

I have also created a local user on the machine, I went into Report Manager as Admin, and at the top level set permissions that should assign the local user to all roles.

When I login to the machine as that user, and then navigate to Report Manager I just get the heading for the page, but do not see any of the folders that are configured.

I've checked and the folders are set to inherit parent permissions and they are showing the newly created local user in there too.

It seems odd that I have set the permissions, yet SSRS is still not showing what I should be able to see. Is there another step I need to take other than configuring the permissions in Report Manager?

When logged in as the newly created local user:

Report Manager - Shows the heading for the page, but no folders/items

Web Service URL (http://machine/ReportServer) - rsAccessDeniedError
share|improve this question
    
On the Home (root) folder, if you go to Properties - Security, do you see the local user account there? Is this where you set up the local user? –  DForck42 Feb 4 '13 at 15:35
1  
Out of interest, have you tried running IE as an admin? There are issues connecting locally with IE when it is not. –  Nic Feb 4 '13 at 21:02
    
I did add the permission at the root folder, and I see the user listed here under Properties - Security. Also I have ran IE as admin, had to do this to be able to get the option for setting permissions. Once set it seems very hit and miss whether they take effect. I tried creating another user, granted them permissions at the root folder, then when I logged in as that user and tried to access Report Manager I don't see any folders/items at all. –  Dan Harris Feb 5 '13 at 12:44
    
Do you have active directory where you're doing this? Also, are you naming the users as servername/username in SSRS? –  DForck42 Feb 6 '13 at 21:13
    
One more thing, could you provide a screen shot of the permissions you're setting? –  DForck42 Feb 6 '13 at 21:14

2 Answers 2

To give a user rights to work with SSRS they need to have permissions at the root folder (which is what it sounds like you have done), but you also have to go into the "site settings" link into the "security" tab and add the user as (at minimum) a system user. It is easy to do one, but not the other. Both are required to allow full access to the system.

share|improve this answer

In addition to Mr. Bennett's comment, I have run into some problems on Windows machines using UAC where the browser needs to run 'as Administrator'. Sometimes there are IE Enhanced Security settings that need to be adjusted (Administrator vs. User).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.