Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

Hello I am using IBM Maximo application which is using DB2 database and I have created only one database. I heard that when paramtere NUMDB has value 8 it will divide all values in DB CONFIGURATION PARAMATERS because it will also get memory for other databases which does not exists. Is this true and should I change value from 8 to 1 because I have only one database? All I could find about this is on this link:

http://pic.dhe.ibm.com/infocenter/db2luw/v9r7/index.jsp?topic=%2Fcom.ibm.db2.luw.admin.config.doc%2Fdoc%2Fr0000278.html

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Information Center is pretty reliable, and I don't see any indication that it will divide memory for non-existent databases. Do you have another link that indicates that?

Otherwise, it is meant to be the maximum number of allowable activated/connected to databases. So there is no need to set it high (I believe by default it is set to something like 12).

Based on the page you have, it is recommended that you set it to the number of databases you have + 10% for room for growth. So if you have 1 database, you would want 1 database + 10% (which in this case would round up) so you would set it to 2.

The reason I believe IBM recommends this, is that you can sometimes get caught with NUMDB less than your number of databases. We have had this happen to us on several occasions in our development and QAT environments. We set the number of databases to something like 9 or 10. And then the developers decided they needed another database. We DBA's ran the CREATE DATABASE script like usual and it didn't fail. However, when the developers tried to access the new database, they got errors (I don't remember the exact SQLCODE off the top of my head). And it turned out we needed to up the value of NUMDB as we had reached the maximum number of activated/connected databases.

So I would follow IBM's recommendation, which in your case would be to set NUMDB to 2. This gives you what you need with some room for growth.

I think this also might not be a "hot" setting, thus requiring you to run db2stop and db2start for it to take affect.

share|improve this answer
    
thank you. I change it and set itr from 8 to 2 –  Dejan Feb 20 '13 at 15:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.