Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

I have a master database running mysql 5.5.11, and I am planning to setup a new slave. I am planning to use the 5.5.30 as it is the latest version. For setting up new slave, I am copying files from master 5.5.11 version. Will there be any compatibility issues?

share|improve this question

2 Answers 2

Your replication configuration 5.5.11 -> 5.5.30 is a supported configuration and there is no real justification for deploying a new slave using old software.

In fact, MySQL replication is supported across major releases as long as the two releases are consecutive, so 5.1.x -> 5.5.x is supported and 5.5.x -> 5.6.x is supported.

The only caveats are that the slave should be the same version as -- or newer than -- the master, and if you're doing circular replication, you should not have more than two versions of MySQL in the chain (and best practice suggests that they be identical in this case).

http://dev.mysql.com/doc/refman/5.5/en/replication-compatibility.html

If you are copying the files from another machine of a different version, don't forget to run mysql_upgrade on the new slave.

share|improve this answer
    
This is so true. Many debate trying to go the other way but the binlog_format STATEMENT has binlogs start in different locations : dba.stackexchange.com/a/12531/877 . +1 !!! –  RolandoMySQLDBA Feb 23 '13 at 2:39

I guess it's good to have the same version at both ends. By good, I mean that 5.5.11 might have bugs that have been fixed in 5.5.30 with respect to replication, so I guess it's safer to use the same versions.

Of course, you can always try and test with your data. But test well. You can run this scenario for a few days to see if something comes up.

share|improve this answer
    
I am worried now. I will go back to 5.5.11. –  Boolean Feb 22 '13 at 20:04
    
You shouldn't worry much. As I said, test before using 5.5.30. If you can run this setup for some time, you will have more confidence that the different versions solution works fine (for your setup always). I guess you cannot upgrade the master to 5.5.30, this would be the best option. –  Vasilis Lourdas Feb 22 '13 at 20:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.