Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

Via Homebrew I just upgraded from MySQL 5.5.29 to 5.6.10 and all my queries and existing users are working fine, but whenever I try to modify permissions or create users now MySQL disconnects me. Are there any my.cnf settings I need to change for 5.6, or system table updates I need to do etc?

mysql> create user 'something'@'localhost' identified by 'password';
ERROR 2013 (HY000): Lost connection to MySQL server during query

mysql> create user 'something'@'localhost' identified by 'password';
ERROR 2006 (HY000): MySQL server has gone away
No connection. Trying to reconnect...
Connection id:    1
Current database: *** NONE ***

ERROR 2013 (HY000): Lost connection to MySQL server during query

mysql> SHOW VARIABLES LIKE "%version%";
ERROR 2006 (HY000): MySQL server has gone away
No connection. Trying to reconnect...
Connection id:    1
Current database: *** NONE ***

+-------------------------+---------------------+
| Variable_name           | Value               |
+-------------------------+---------------------+
| innodb_version          | 1.2.10              |
| protocol_version        | 10                  |
| slave_type_conversions  |                     |
| version                 | 5.6.10              |
| version_comment         | Source distribution |
| version_compile_machine | x86_64              |
| version_compile_os      | osx10.8             |
+-------------------------+---------------------+
7 rows in set (0.00 sec)
share|improve this question

1 Answer 1

up vote 9 down vote accepted

Alright another instance of "read your damn logs" :)

tail /usr/local/var/mysql/username.local.err told me:

2013-02-25 11:29:50 1616 [ERROR] Native table 'performance_schema'.'accounts' has the wrong structure
2013-02-25 11:29:50 1616 [ERROR] Native table 'performance_schema'.'hosts' has the wrong structure
2013-02-25 11:29:50 1616 [ERROR] Native table 'performance_schema'.'socket_instances' has the wrong structure
2013-02-25 11:29:50 1616 [ERROR] Native table 'performance_schema'.'socket_summary_by_instance' has the wrong structure
...

So a quick google turned up the answer: sudo mysql_upgrade -u root -ppass

share|improve this answer
    
+1 for finding your own solution, which was also in the manual. :) dev.mysql.com/doc/refman/5.6/en/… –  Michael - sqlbot Feb 26 '13 at 1:49
    
That works and you'd probably want to run the update under sudo. –  user24048 May 21 '13 at 15:40
    
+1 for this. This helped me finding and resolving the issue quickly! –  Jan Thomä Jan 23 at 11:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.