Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

Running a 24 core server (with HT enabled) I tried increasing MaxNoOfExecutionThreads to 24 to perform some benchmarks and got the following error:

2013-02-27 11:21:44 [ndbd] INFO -- Trying to start 12 LQH workers with only 4 log parts, try initial node restart to be able to use more LQH workers.

Here are options from config.ini I find relevant:

NoOfFragmentLogFiles=64

FragmentLogFileSize=128M

It seems that Redo Log file number (not fragment) is always four and they are created in D9-D11 directory on the FS. I haven't been able to find a parameter to change this.

Version running is: 5.5.29-ndb-7.2.10

Any help or experience is welcome.

EDIT - solution: The following option defines the number of Redo log files - NoOfFragmentLogParts

After setting it to 12, you get D8-D19 for Redo Logs and 24 as MaxNoOfExecutionThreads works fine.

share|improve this question
    
I just ran into this exact same problem. I can't figure it out either. –  Dave Feb 27 '13 at 19:37
    
I EDIT-ed the questions as it seems the solution is hidden in the docs. –  Nimzo Feb 27 '13 at 23:09

1 Answer 1

You can try and set

[NDBD DEFAULT]
...

NoOfFragmentLogParts=12
...

http://dev.mysql.com/doc/refman/5.5/en/mysql-cluster-ndbd-definition.html#ndbparam-ndbmtd-nooffragmentlogparts

Then restart all nodes with --initial

Best regards

Johan Andersson

Severalnines AB

share|improve this answer
    
Yeah, I edited the question after finding the solution but thanks anyway. –  Nimzo Feb 28 '13 at 17:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.