Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

I installed the Oracle 11g server on Ubuntu 12.10. But I can't start the server. When I start up the server, the following error occurs.

SQL> startup
ORA-01078: failure in processing system parameters
LRM-00109: could not open parameter file '/u01/app/oracle/product/11.2.0/xe/dbs/initXE.ora'

How can I solve this issue? I think the connect failed because target host or object does not exist. How can a target host be specified?


Update as requested. Running:

$ ls -latr /u01/app/oracle/product/11.2.0/xe/dbs/initXE.ora

returns:

-rw-r--r-- 1 oracle dba 2637 Mar 13 17:07 /u01/app/oracle/product/11.2.0/xe/dbs/initxe.ora 
share|improve this question

migrated from askubuntu.com Mar 13 '13 at 18:26

This question came from our site for Ubuntu users and developers.

    
What is the output of "ls -latr /u01/app/oracle/product/11.2.0/xe/dbs/initXE.ora" –  BryceAtNetwork23 Mar 13 '13 at 14:38
    
hi ,thanks for your comment .the out put is -rw-r--r-- 1 oracle dba 2637 Mar 13 17:07 /u01/app/oracle/product/11.2.0/xe/dbs/initxe.ora –  Praneeth Pj Mar 13 '13 at 15:29
    
Ok, how about the output of "echo $ORACLE_SID" –  BryceAtNetwork23 Mar 13 '13 at 15:33
    
it is nothing display.start a empty line ! –  Praneeth Pj Mar 13 '13 at 15:48
    
ls initXE.ora will not return initxe.ora. Unix is case sensitive. –  miracle173 May 24 at 22:29
add comment

3 Answers 3

I see two things wrong here. Oracle tries to open a parameter file in the $ORACLE_HOME/dbs directory with the format "spfile" + $ORACLE_SID + ".ora". If it cannot find it, it then tries to open "init" + $ORACLE_SID + ".ora". This is where the problem(s) are.

By virtue of the fact that Oracle is trying to open a parameter file named "initXE.ora", your SID must be (or was at one point) equal to "XE".

1) This is the easy part, so try this first. Since (in your comments) doing an echo $ORACLE_SID yields nothing, try setting it.

export ORACLE_SID=XE

Then try starting Oracle again.

2) In your comments above, you show the file is named "initxe.ora". Is that really the name of the file? Or did your paste into a comment somehow lowercase the output of the ls command?

The reason I point this out, is that Ubuntu (Linux) has a case-sensitive filesystem. So initxe.ora and initXE.ora are actually two different files. So if your comment is correct and the file is lower-cased, you'll want to set your ORACLE_SID to "xe" instead:

export ORACLE_SID=xe

Try that, and see if it works.

share|improve this answer
    
thanks for your answer it is really helpful.but this error is below occurred.this is my first time installing oracle on the linux os.ORA-48108: invalid value given for the diagnostic_dest init.ora parameter ORA-48140: the specified ADR Base directory does not exist [/u01/app/oracle/product/11.2.0/xe/dbs/<ORACLE_BASE>] ORA-48187: specified directory does not exist Linux-x86_64 Error: 2: No such file or directory Additional information: 1 –  Praneeth Pj Mar 14 '13 at 3:06
add comment

find "initXE.ora" in your oracle directory and used :
SQL> startup pfile=<directory_name>/initXE.ora

share|improve this answer
    
You might want to add some details about why this works, or what the problem is with the original poster's question. –  Max Vernon Jan 1 at 20:48
add comment

Just do ls -altr. If you find like this ...

-rw-r--r-- 1 oracle oinstall 2637 Mar 13 init.ora

... just change the owner: chown -R oracle:dba init.ora, then startup.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.