Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

This one's had both me and our dba scratching our heads.

We have an Oracle 11.1.0.7.0 instance, DEV, with a user who can successfully connect to our ldap server, e.g.:

DECLARE
  l_session DBMS_LDAP.session;
BEGIN
  l_session := DBMS_LDAP.init('ldap.host.bla.bla',389);
END;
/

PL/SQL procedure successfully completed

We have another Oracle instance, 11.2.0.3.0 called UAT, with the same user, same set up, but when they run the above code, it raises an exception from DBMS_LDAP:

ORA-24247: network access denied by access control list (ACL)

In both instances, if I run the following queries, no rows are returned:

select * from dba_network_acls;

select * from dba_network_acl_privileges;

To fix this problem in UAT, we've created a suitable network ACL using DBMS_NETWORK_ACL_ADMIN.create_acl. Now, UAT works fine.

What's bothering us is that this worked fine in DEV all along, with apparently no network ACLs created. Our only theory is a bug in the version in DEV (11.1.0.7.0) but I hesitate to just leap on that as a conclusion.

We will soon be upgrading DEV to 11.2 to be consistent with the other environments, but before then, is there anything else I can check to see what difference there is between the two environments that might cause this behaviour?

(Background for those unfamiliar with ACLs: http://www.oracle-base.com/articles/11g/fine-grained-access-to-network-services-11gr1.php)

share|improve this question
    
How was UAT created from DEV? Or was it installed separately and messed with over a period of time? –  Phil Mar 28 '13 at 1:04
    
UAT was created separately. We deployed the new user using the same scripts used in DEV. However, the dba who set up DEV is no longer with the organisation; he sent our new dba some scripts (which basically just create the ACL) but he doesn't remember doing anything else differently in dev. –  Jeffrey Kemp Mar 28 '13 at 1:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.