Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

this is my first time to install Oracle 11g R2 on Linux.

I made all instructions in Oracle documentation.

But in the installation process, the Net Configuration Manager is failed.

I continued the process, and after it finished, I couldn't connect to the sqlplus.

This is my tnsnames.ora

# tnsnames.ora Network Configuration File: /Oracle/u01/app/oracle/product/11.2.0/db_1/network/admin/tnsnames.ora
# Generated by Oracle configuration tools.

ORCL =
  (DESCRIPTION =
    (ADDRESS = (PROTOCOL = TCP)(HOST = localhost.localdomain)(PORT = 1521))
    (CONNECT_DATA =
      (SERVER = DEDICATED)
      (SERVICE_NAME = orcl.localhost)
    )

and listener.ora

# listener.ora Network Configuration File: /Oracle/u01/app/oracle/product/11.2.0/db_1/network/admin/listener.ora
# Generated by Oracle configuration tools.

LISTENER =
  (DESCRIPTION_LIST =
    (DESCRIPTION =
      (ADDRESS = (PROTOCOL = TCP)(HOST = localhost.localdomain)(PORT = 1521))
    )
  )

ADR_BASE_LISTENER = /Oracle/u01/app/oracle

Output of lsnrctl status

LSNRCTL for Linux: Version 11.2.0.1.0 - Production on 29-MAR-2013 02:35:48

Copyright (c) 1991, 2009, Oracle.  All rights reserved.

Connecting to (DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(HOST=localhost.localdomain)(PORT=1521)))
TNS-12541: TNS:no listener
 TNS-12560: TNS:protocol adapter error
  TNS-00511: No listener
   Linux Error: 111: Connection refused

I open ./netca to reconfigure the listener again.

But the program told me that the port is in use.

I deleted it and added a new one but the same warning that port is in use

**

Solution:

** Finally I found the solution, that I didn't change permission to be owned by oracle user and oinstall group for the database dir in which the oracle software is. And I think that there are some scripts or programs that related to listener and the oracle user cannot run it.

share|improve this question
    
You can issue ps auxww | grep tnslsnr to find out PIDs of the listeners occupying the ports, and kill these processes, e. g. kill -s 9 1234. Then try to reconfigure your listener with Net Configuration Assistant (netca) and start it with lsnrctl start YOU_LISTENER_NAME. –  Yasir Arsanukaev Mar 29 '13 at 9:52
    
Doesn't work also –  UNIX Mar 29 '13 at 13:23
    
when I kill the process that use this port (1521). and reconfigure the LISTENER, the same message appear that the port is used. –  UNIX Mar 29 '13 at 13:25
    
Looks like there's some sort of network configuration issue. Make sure the IPv4 and IPv6 stacks are configured properly. I would temporarily disable IPv6. Try to use IP address in listener.ora, e. g. 127.0.0.1. –  Yasir Arsanukaev Mar 29 '13 at 13:30
    
I mad all your recommendation and it doesn't work. When I run this command lsnrctl status: ...... The listener supports no services ...... –  UNIX Mar 29 '13 at 13:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.