Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.
sqlplus connect <sys>/<pwd>
grant execute on utl_file to <user>
connect <user>/<pwd>
DESC utl_file

then i get: ORA-24372: invalid object for describe

How can I access to UTL_FIL from other users in 11g xe? I already tried with public as well

share|improve this question

1 Answer 1

The grant worked just fine. You can't DESC a package or procedure, which is why you're getting an error.

Documentation for UTL_FILE is here. It provides sample PL/SQL that shows you how to use the package.

A short code snippet that sums up its functionality is here.

share|improve this answer
    
why if I do it under SYS I can DESC it? Also in can desc it in the full version of 11g –  Edu Apr 11 '13 at 8:21
    
@Edu is correct, his example can be successfully reproduced in my 11gR2 Enterprise environment, including DESC. –  Yasir Arsanukaev Apr 11 '13 at 8:46

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.