Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

This morning when I logged into SQL Server Management Studio (v 10.0.16) I clicked on the databases node and saw all by db's (they are hosted remotely) as I have done for the last 3 years. This evening, when I click on the databases node I see NOTHING - except the system databases.

According to my hosting company, this is an issue with my local permissions. I have searched everywhere and found nothing to help me. I'm now desperate and and help would be massively appreciated.

share|improve this question

migrated from stackoverflow.com Apr 16 '13 at 21:15

This question came from our site for professional and enthusiast programmers.

    
This is very common with many hosting companies, they host many databases and there is limit on how many databases can be viewed in SSMS, if it crosses 2500 it will not show any databases, to fix this Go to View > Object Explorer Details, then find your database and click on that to see objects under your database –  rs. Apr 14 '13 at 17:24
add comment

1 Answer 1

Have you tried logging in with your sa (system administration) account? This account should have permissions to see everything, and also reassign permissions to your usual account.

share|improve this answer
    
this is hosted database and OP will not have SA account access. –  rs. Apr 14 '13 at 17:29
    
@rs: Good point, but still it would depend, I'd say. If he has a hosted VM with the instance, for example, there is a chance he has access. –  carlpett Apr 14 '13 at 17:31
    
thanks, but I don't have the option to login as sa. according to my hosting company it's a local prob. They say they've tested it on other PCs and it works fine. If they are right then it implies it's something that has been altered on my PC - perhaps by a windows update ? –  Tim Sharp Apr 14 '13 at 19:03
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.