Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

From cmd.exe, when I run:

C:\oracle\client\BIN\sqlplus.exe username@server

then type my password, I get in. However, if I run the same command from PowerShell and type the same password I get:

ERROR:
ORA-01017: invalid username/password; logon denied

After searching for a bit and making triply sure that I'm typing my password right I still can't figure out why SQLPlus isn't working for me from PowerShell. What am I missing?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Arg, found the problem. My username is ops$account and PowerShell treats $ as a start of variable token. Because $account was null the username I was passing was just "ops". I fixed the issue by escaping the $ with the backtick, i.e.

C:\oracle\client\BIN\sqlplus.exe ops`$account@server
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.