Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

I have multi-master replication and using Zabbix for server monitoring. Since the replication is row based, I get this error in slave everytime which also breaks my replication. The error I get is:

Last_SQL_Error: Could not execute Delete_rows event on table zabbix.history_uint; Can't find record in 'history_uint', Error_code: 1032; handler error HA_ERR_KEY_NOT_FOUND; the event's master log mysql-bin.000137, end_log_pos 103587

I have been through several posts and bug reports in mysql forums, still couldn't figure out what is breaking it. There were few interesting conversations like this, but nothing suggests to help.

Steps I tried:

  • Only Select permission in Slave (by the error, it still it looks like it is trying to execute delete command, but again same error)
  • Reset Slave while fixing the replication like adjusting the bin-log and position from master to slave.

So, any help how to fix this would be appreciated.

Edit:
If it helps then I have the show create table query here

show create table history_uint \G;
*************************** 1. row ***************************
       Table: history_uint
Create Table: CREATE TABLE `history_uint` (
  `itemid` bigint(20) unsigned NOT NULL DEFAULT '0',
  `clock` int(11) NOT NULL DEFAULT '0',
  `value` bigint(20) unsigned NOT NULL DEFAULT '0',
  KEY `history_uint_1` (`itemid`,`clock`)
) ENGINE=InnoDB DEFAULT CHARSET=utf8
1 row in set (0.00 sec)

Edit2:
Even after revoking all the permissions (except select) in slave for user I still get the same error and my replication breaks.

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.