Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

Im trying to start Mysql using easyPHP : the response is an alert window to a log file. The main error is <-- Plugin 'FEDERATED' is disabled -->.

Through my research on internet i found that the solution is to add the federated option to "my.ini" file. I did this but it is still not working.

Here is an extract from the log file for more information :

 2013-05-03 14:12:57 3776 [Note] Plugin 'FEDERATED' is disabled.
    2013-05-03 14:12:57 1b4c InnoDB: Warning: Using innodb_additional_mem_pool_size is DEPRECATED. This option may be removed in future releases, together with the option innodb_use_sys_malloc and with the InnoDB's internal memory allocator.
    2013-05-03 14:12:57 3776 [Note] InnoDB: The InnoDB memory heap is disabled
    2013-05-03 14:12:57 3776 [Note] InnoDB: Mutexes and rw_locks use Windows interlocked functions
    2013-05-03 14:12:57 3776 [Note] InnoDB: Compressed tables use zlib 1.2.3
    2013-05-03 14:12:57 3776 [Note] InnoDB: Not using CPU crc32 instructions
    2013-05-03 14:12:57 3776 [Note] InnoDB: Initializing buffer pool, size = 16.0M
    2013-05-03 14:12:57 3776 [Note] InnoDB: Completed initialization of buffer pool
    2013-05-03 14:12:57 3776 [Note] InnoDB: The first specified data file .\ibdata1 did not exist: a new database to be created!
    2013-05-03 14:12:57 3776 [Note] InnoDB: Setting file .\ibdata1 size to 12 MB
    2013-05-03 14:12:57 3776 [Note] InnoDB: Database physically writes the file full: wait...
    2013-05-03 14:12:57 3776 [Note] InnoDB: Setting log file .\ib_logfile101 size to 5 MB
    2013-05-03 14:12:57 3776 [Note] InnoDB: Setting log file .\ib_logfile1 size to 5 MB
    2013-05-03 14:12:57 3776 [Note] InnoDB: Renaming log file .\ib_logfile101 to .\ib_logfile0
    2013-05-03 14:12:57 3776 [Warning] InnoDB: New log files created, LSN=45781
    2013-05-03 14:12:57 3776 [Note] InnoDB: Doublewrite buffer not found: creating new
    2013-05-03 14:12:57 3776 [Note] InnoDB: Doublewrite buffer created
    2013-05-03 14:12:57 3776 [Note] InnoDB: 128 rollback segment(s) are active.
    2013-05-03 14:12:57 3776 [Warning] InnoDB: Creating foreign key constraint system tables.
    2013-05-03 14:12:57 3776 [Note] InnoDB: Foreign key constraint system tables created
    2013-05-03 14:12:57 3776 [Note] InnoDB: Creating tablespace and datafile system tables.
    2013-05-03 14:12:57 3776 [Note] InnoDB: Tablespace and datafile system tables created.
    2013-05-03 14:12:57 3776 [Note] InnoDB: Waiting for purge to start
    2013-05-03 14:12:57 3776 [Note] InnoDB: 5.6.11 started; log sequence number 0
    2013-05-03 14:12:58 3776 [Warning] No existing UUID has been found, so we assume that this is the first time that this server has been started. Generating a new UUID: cadcd135-b3ea-11e2-92bc-e0db55e1304d.
    2013-05-03 14:12:58 3776 [Note] Server hostname (bind-address): '127.0.0.1'; port: 3306
    2013-05-03 14:12:58 3776 [Note]   - '127.0.0.1' resolves to '127.0.0.1';
    2013-05-03 14:12:58 3776 [Note] Server socket created on IP: '127.0.0.1'.
    2013-05-03 14:12:58 3776 [Warning] InnoDB: Cannot open table mysql/slave_master_info from the internal data dictionary of InnoDB though the .frm file for the table exists. See http://dev.mysql.com/doc/refman/5.6/en/innodb-troubleshooting.html for how you can resolve the problem.
    2013-05-03 14:12:58 3776 [Warning] Info table is not ready to be used. Table 'mysql.slave_master_info' cannot be opened.
    2013-05-03 14:12:58 3776 [Warning] InnoDB: Cannot open table mysql/slave_worker_info from the internal data dictionary of InnoDB though the .frm file for the table exists. See http://dev.mysql.com/doc/refman/5.6/en/innodb-troubleshooting.html for how you can resolve the problem.
    2013-05-03 14:12:58 3776 [Warning] InnoDB: Cannot open table mysql/slave_relay_log_info from the internal data dictionary of InnoDB though the .frm file for the table exists. See http://dev.mysql.com/doc/refman/5.6/en/innodb-troubleshooting.html for how you can resolve the problem.
    2013-05-03 14:12:58 3776 [Warning] Info table is not ready to be used. Table 'mysql.slave_relay_log_info' cannot be opened.
    2013-05-03 14:12:58 3776 [Note] Event Scheduler: Loaded 0 events
    2013-05-03 14:12:58 3776 [Note] C:\PROGRA~1\EASYPH~1.1VC\binaries\mysql\bin\mysqld.exe: ready for connections.
    Version: '5.6.11-log'  socket: ''  port: 3306  MySQL Community Server (GPL)
    2013-05-03 14:15:59 3776 [Note] C:\PROGRA~1\EASYPH~1.1VC\binaries\mysql\bin\mysqld.exe: Normal shutdown
share|improve this question
add comment

1 Answer 1

2013-05-03 14:12:57 3776 [Note] Plugin 'FEDERATED' is disabled.

This isn't an error, it's information only, which is why it is tagged as [Note]. If you aren't trying to use the FEDERATED storage engine, you can disregard this.

However, if you've added this to your my.ini file and the notice still comes up, then you probably have more than one my.ini file on your system, and the one you're editing is not the correct one.

What's unclear, here is why you say "it is still not working." What isn't working? MySQL is starting up.

2013-05-03 14:12:58 3776 [Note] C:\PROGRA~1\EASYPH~1.1VC\binaries\mysql\bin\mysqld.exe: ready for connections.

Windows doesn't have unix sockets, so this looks normal, too:

Version: '5.6.11-log'  socket: ''  port: 3306  MySQL Community Server (GPL)

Then about 3 minutes later, you or somebody shut it down again.

2013-05-03 14:15:59 3776 [Note] C:\PROGRA~1\EASYPH~1.1VC\binaries\mysql\bin\mysqld.exe: Normal shutdown

...so what is it that "is still not working?" Is this a new install? An upgrade?

There is also an EasyPHP faq that addresses a number of issues related to starting MySQL.

share|improve this answer
    
Thank you for your answer. Actually i relaunched mysqld.exe. Apparently MySQL is working (i have checked that from the task manager). My problem now is : Trying to log in to MySQL with the following command : mysql -u root -h 127.0.0.1 -p; I have this response : access denied for user root '@' localhost'. –  enzo May 8 '13 at 8:26
    
EasyPHP apparently (gasp) installs MySQL with an empty root password... so unless you have set that password, you should probably not specify the -p. –  Michael - sqlbot May 8 '13 at 16:39
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.