Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

OS: RHEL

DB: Oracle 11g version 11.1.0.7.0

I am trying to clone a database on one environment (environment A) to another database on a separate environment (Environment B). Environment B's database is an out-of-date clone of Environment A's database. What would be the best methods for exporting the data from the database on environment A, and importing it to the database on environment B? I have tried using the export and import data pump to do this but it has been unsuccessful for importing the full database.

Also, we use Oracle Warehouse Builder to load data into the databases. When there are issues loading the data I currently restore a previous snapshot of the virtual machine prior to loading the data. Is there also a method to export the data prior to loading data, and then importing it again if there are issues when loading the data? Would export and import data pumps solve this issue?

Thanks!

share|improve this question
    
Did you consider Duplicating a Database with DUPLICATE command? Or do you need just a subset of data, not a whole database? In the latter case Oracle Data Pump is a reasonable tool. –  Yasir Arsanukaev May 14 '13 at 3:57
    
Hi Yasir, For the first case (cloning the database) rman duplicate has been suggested. However, what I need is to export all the database objects. The database on environment B is a clone of the one on A. So would Oracle Data Pump not be a good option to replace the old data objects with more updated? On the latter case, when I run the import it appears to work for individual schemas, but not the full database. Here is a link to the logfile: dl.dropboxusercontent.com/u/13107793/logs.zip –  okpjc May 15 '13 at 1:17
    
Did you try CONTENT Data Pump parameter? If you specify CONTENT=DATA_ONLY, Data Pump will not (un)load any object definitions, only row data is (un)loaded. This is a valid parameter for both Export and Import. –  Yasir Arsanukaev May 15 '13 at 1:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.