Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I run a checkdb('mydb') this is the only error message printed.

Msg 8992, Level 16, State 1, Line 1
Check Catalog Msg 3857, State 1: The attribute (clr_name=NULL) is required but is missing for row (assembly_id=1) in sys.assemblies.

It is referring to 'Microsoft.SqlServer.Types' I do see that in the this db the clr_name is blank. but under the master db there is a value in there.

I tried to drop or alter the assembly to add this value but its restricted.

btw, this db was updated lately from sql-server 2005 to 2008R2.

share|improve this question
Did you add SqlServer.Types as an assembly to the database before the update, on the SQL Server 2005 instance? – Remus Rusanu May 26 '13 at 20:41
yes I did. but any way I redid the full database now. and it looks like this will work – Ezi May 26 '13 at 20:42
up vote 0 down vote accepted

After searching online a lot, I see the only option to fix that type of corruption is to recreate the database objects and move all the data.

(or restore a backup if available)

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.