Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

I am experiencing a very weird behaviour from the Management Studio GO.
I am following the full-Text Search tutorial and I run the following query over adventure works

 SELECT FT_TBL.ProductDescriptionID,
 FT_TBL.Description, 
 KEY_TBL.RANK
 FROM Production.ProductDescription AS FT_TBL INNER JOIN
    CONTAINSTABLE (Production.ProductDescription,
      Description, 
      '(light NEAR aluminum) OR
      (lightweight NEAR aluminum)'
    ) AS KEY_TBL
    ON FT_TBL.ProductDescriptionID = KEY_TBL.[KEY]
 WHERE KEY_TBL.RANK > 2
 ORDER BY KEY_TBL.RANK DESC;

When I run it with GO (before the query ) and without GO and the results are different. I played with it some more - copied the select and added go between and the results are still different. Notice from the picture that it is the same select written twice but with two different results

enter image description here

Any idea?

EDIT: Just discovered the execution plan is different because of the go:

enter image description here

share|improve this question

closed as off topic by Jon Seigel, RolandoMySQLDBA, dezso, Mat, StanleyJohns May 28 '13 at 14:20

Questions on Database Administrators Stack Exchange are expected to relate to database administration within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Can you check the statement that shows up at the top of each execution plan to see if it matches the original? That might give a clue. Unfortunately the image you posted isn't wide enough to capture the whole thing. –  Jon Seigel May 27 '13 at 16:51
2  
@JonSeigel This is a duplicate from this Q on SO: stackoverflow.com/questions/16775671/… . The issue was reproduced by gbn and myself. This is the new connect item created for it: connect.microsoft.com/SQLServer/feedback/details/788691/… –  Lamak May 27 '13 at 17:22
    
I can't reproduce this on AdventureWorks2008 –  Rohan May 27 '13 at 17:39
2  
@Lamak: Thanks. OP: please don't cross-post. Thanks. –  Jon Seigel May 27 '13 at 19:13