Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

I have SQL Servers across locations setup for replication. One of the SQL Server instances that I installed, running locally I can see the green button with the white arrow in the object explorer when I connect to it. However, when I connect to it from any other location, I cannot see that or neither can I start or Stop the SQL Serer Agent; even though locally I am able to do that.

Additionally, the MDTC doesn't has only 2 items sent both with were rejected, where as other servers have 100's committed and sent. Is there something wrong with the DTC settings?

Please help.

share|improve this question
    
The Windows account launching SSMS need to have appropriate permissions to the cimv2 namespace in WMI. Service status watcher in SQL Server Management Studio – How it works (blogs.msdn.com/b/psssql/archive/2013/08/22/…) –  Kin Aug 26 '13 at 21:37
add comment

2 Answers

Your best bet is to download DTCPing (http://www.microsoft.com/en-us/download/details.aspx?id=2868) and run it from both machines. If I recall correctly, the servers initially talk over the RPC port (135) and then negotiate a random, high port (above 1024) to continue the transaction on. There is a registry entry that will allow you to limit the ports RPC chooses, but it will apply to all RPC calls not just DTC calls. http://support.microsoft.com/kb/908472

share|improve this answer
add comment

I have MSSQL servers across locations setup for replication. One of the MSSQL server that I installed, running locally I can see the green button with the white arrow in the object explorer when I connect to it. However, when I connect to it from any other location, I cannot see that or neither can I start or Stop the SQL Serer Agent; even though locally I am able to do that.

Most likely caused by WMI service (windows Management Instrumentation) on the machine housing SQL server being blocked by firewall, make sure that you open appropriate ports (Port 135) and other dynamically assign ports used by WMI.

Another reason you are accessing SQL server using SQL Authentication in non trusted domains.

share|improve this answer
    
The service is up and running. And the domain is also trusted as well. –  user24250 May 27 '13 at 20:16
    
and it is not blocked by firewall... –  SQL Learner May 27 '13 at 20:53
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.