Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

Ok, Here is my story, I went to mysql.com site & downloaded the file mysql-5.6.11-winx64.zip into C:, then I unziped it. Then I went to bin folder & started the server by using this command:

C:\mysql-5.6.11-winx64\bin\mysqld --standalone --local-infile=1

Everything was ok as the Mysql server started smoothly. I then stopped server using this command:

C:\mysql-5.6.11-winx64\bin\mysqladmin -u root shutdown

The Server was shutdowned properly.

I used this way to start & stop mysql server a few times without any problem.

However, yesterday, I started the Mysql server but then, at the end of the day, i turned off my PC while my MySQL server was still in the Starting Mode (ie, i did not shutdown mysql using "bin\mysqladmin -u root shutdown" before turned off my PC).

Also, when my PC got turned off at that time, the Win 7 was starting to download some packages from the internet to update Win7 so the configuration of win7 could be changed.

But today I could not start Mysql Server using the above command as there's an error:

[Warning] TIMESTAMP with implicit DEFAULT value is deprecated. Please use --explicit_defaults_for_timestamp server option (see documentation for more details).

I searched over internet & some people said that I have to go to my.cnf file & add this line into:

explicit_defaults_for_timestamp = TRUE

However, there is no my.cnf file in mysql 5.6, there a lot of cnf file in mysql5.6 but with different names:

mysql-5.6.11-winx64\data\auto.cnf
mysql-5.6.11-winx64\mysql-test\include\default_client.cnf
mysql-5.6.11-winx64\mysql-test\include\default_my.cnf
mysql-5.6.11-winx64\mysql-test\include\default_mysqld.cnf
mysql-5.6.11-winx64\mysql-test\include\default_mysqld_autosize.cnf
mysql-5.6.11-winx64\mysql-test\include\default_mysqld_ndbd.cnf

I tried to add explicit_defaults_for_timestamp = TRUE into all above cnf file but no help, i still couln't start mysql

I don't want to reinstall cos I created a big DB in the current mysql Server.

So how to fix it?

Note: when first time I ran Mysql server, win7 pop up a message saying something (i couldn't remember) such as "do you allow ... Firewall", so do u think that is causing the issue since Win7 got its configuration updated & somehow it reset the Firewall so the Mysql server couldn't start?

share

migration rejected from stackoverflow.com May 31 '13 at 15:58

This question came from our site for professional and enthusiast programmers. Votes, comments, and answers are locked due to the question being closed here, but it may be eligible for editing and reopening on the site where it originated.

closed as too localized by jcolebrand May 31 '13 at 15:58

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.