Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

I'm having the strangest issue. I have a very basic (I think) setup of an Oracle 11G database on one Hyper-V VM, and the Oracle 11G client on another VM. Although I'm able to access the database on the local VM (sqlplus USER/PASS@XE), doing so from the other VM (i.e. sqlplus USER/PASS@VM1) doesn't work.

This sounds like an easy one you probably think... until you look at the list of stuff I've tried to get this working.

  1. Double-checking the TNSNames file - that's definitely set up correctly on both machines.
  2. Double-checking the Listener file - that seems OK:

    SID_LIST_LISTENER =
      (SID_LIST =
        (SID_DESC =
          (SID_NAME = PLSExtProc)
          (ORACLE_HOME = C:\oraclexe\app\oracle\product\11.2.0\server)
          (PROGRAM = extproc)
        )
        (SID_DESC =
          (SID_NAME = CLRExtProc)
          (ORACLE_HOME = C:\oraclexe\app\oracle\product\11.2.0\server)
          (PROGRAM = extproc)
        )
      )
    
    LISTENER =
      (DESCRIPTION_LIST =
        (DESCRIPTION =
          (ADDRESS = (PROTOCOL = IPC)(KEY = EXTPROC1))
          (ADDRESS = (PROTOCOL = TCP)(HOST = VM1)(PORT = 1521))
        )
      )
    DEFAULT_SERVICE_LISTENER = (XE)
    
  3. Performing a TNSPing from VM2 to VM1 - that's successful and resolves using TNSNames (rather than EZConnect etc).

  4. Disabling the firewall on both machines - shouldn't have been necessary but by this point I was desperate enough...
  5. Looking at the listener.log file - at this point I think it looks like an IPv6 resolution issue, so I disable IPv6 resolution on both VMs' network adapters.
  6. Trying using software other than SQLPlus to connect to the database - this doesn't work either.
  7. Restarting the Oracle XE Listener service, and then the Oracle Service, on VM1.

Infuriatingly, this doesn't work. There isn't even an error code - it just hangs saying "Connecting" until I do a Ctrl+C on it.

The configuration is Oracle 11G XE (only) installed on VM1 and Oracle 11G Client (only) installed on VM2. Bizarrely, the whole thing DOES work in our server VM environment (i.e. both machines on Windows Server 2008 R2 Hyper-V). Just not in Windows 8 Hyper-V. Network type is set to Internal on the Windows 8 Hyper-V setup. At this point I'm convinced it's a network issue, but since everything else resolves correctly I don't know where to start.

My previous config was having Oracle 10G XE and Oracle 11G Client on VM1 and Oracle 11G Client on VM2. This worked.

Does anyone have any ideas of where they'd look next?

share|improve this question
    
Please add exact error text which SQL*Plus returns after timeout and content of TNSNAMES.ORA and SQLNET.ORA files from client VM. –  ThinkJet Jul 2 '13 at 21:12
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.