Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm on a Red Hat Enterprise Linux Client release 5.4 (Tikanga) machine

I created my /etc/yum.repos.d/10gen.repo like this:

[10gen]
name=10gen Repository
baseurl=http://downloads-distro.mongodb.org/repo/redhat/os/x86_64
gpgcheck=0
enabled=1

I installed MongoDB with: sudo yum install mongo-10gen mongo-10gen-server

but when I run: sudo service mongod start

I get: Missing SERVICE_URI environment variable

help! :)

share|improve this question

That sounds more like a problem with the service command than with MongoDB or the install. Try starting it from init.d instead:

sudo /etc/init.d/mongod start
share|improve this answer

Use /sbin/service instead of service - I had exactly the same problem and that fixed

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.