Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

I started my MYSQL database this morning but failed. And I tried all means I can think of:

chown -R mysql.mysql /var/lib/mysql
chmod g+w /var/run/mysqld
chgrp mysql /var/run/mysqld
chmod -R 755 /var/lib/mysql/
service mysqld stop; mysqld_safe --user=mysql &

but the file is still not there (/var/lib/mysql/mysql.sock). I checked the file /var/log/mysqld.log, it says:

130827 07:49:25 mysqld_safe Starting mysqld daemon with databases from /var/lib/mysql
130827  7:49:26  InnoDB: Initializing buffer pool, size = 8.0M
130827  7:49:26  InnoDB: Completed initialization of buffer pool
130827  7:49:26  InnoDB: Started; log sequence number 0 44233
130827  7:49:26 [ERROR] /usr/libexec/mysqld: unknown option '--qviheadfv<F4><F4>--bdcvadsfefa'
130827  7:49:26 [ERROR] Aborting

130827  7:49:26  InnoDB: Starting shutdown...
130827  7:49:31  InnoDB: Shutdown completed; log sequence number 0 44233
130827  7:49:31 [Note] /usr/libexec/mysqld: Shutdown complete

130827 07:49:31 mysqld_safe mysqld from pid file /var/run/mysqld/mysqld.pid ended

I got totally lost. What is the option '--qviheadfv--bdcvadsfefa'? Any suggestion?

share|improve this question
    
Sounds like potentially garbage in my.cnf or your initscript from improper use of a text editor... or corruption of one of those files on disk. Check those? –  Michael - sqlbot Aug 27 '13 at 3:37
    
Thanks a lot! as you said, I deleted one line below and it turned normal: datadir=/var/lib/mysql socket=/var/lib/mysql/mysql.sock user=mysql # Disabling symbolic-links is recommended to prevent assorted security risks symbolic-links=0 qviheadfv<F4><F4>--bdcvadsfefa servaer_id=2 log-bin=mysql-bin master-host=***.***.**.*** master-user=root master-password=***** master-port=3306 master-connect-retry=10 replicate-do-db=abc replicate-ignore-db=mysql –  leoce Aug 29 '13 at 1:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.