Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

I would like to upgrade a PostgreSQL 8.3 server to PostrgreSQL 8.4. There are many software components that interact with the server over the network, and I am concerned with compatibility issues.

Is there any interface change between the different versions of PostgreSQL, as far as an external component is concerned?

share|improve this question

3 Answers 3

up vote 2 down vote accepted

Unfortunately, without knowing your system (inside and out), it's going to be difficult for anyone to tell you how an upgrade is going to impact you.

I'd recommend checking the release notes to verify that the upgrade path won't mess up the application.

Here are a couple changes that I noticed that you might need to know about:

  • Remove ipcclean utility command

  • Changes in the TRUNCATE and LOCK statements

  • SELECT DISTINCT and UNION/INTERSECT/EXCEPT no longer always produce sorted output

  • Disallow LOCK TABLE outside a transaction block

  • Remove support for the (insecure) crypt authentication method

  • Modify the ALTER TABLE syntax to allow all reasonable combinations for tables, indexes, sequences, and views

I'd recommend trying this on a test machine first (if possible).

share|improve this answer

You should carefully(!) read the changes from 8.4 to 8.3. See if anything relates to your setup and fix it accordingly.

share|improve this answer

I don't know of any changes that break backwards-compatibility - see here for some general upgrade hints as you can't use pg_upgrade

You will of course want to test the upgrade away from your production environment first

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.