Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

I basically fail to view data in the new Workbench version without firing queries. I recall it was clearly possible in the previous version by simply using context menu something like "view table data".

Now in 6.0 I can't see this option anymore. Though I can see "search table data" which gives me next window where I have to input some mysterial query the pattern of which I fail to recognize. (see second screenshot - Start Search button is disabled)

enter image description here

enter image description here

It is not a big problem for me to fire queries, but still this is quite annoying especially if you don't see sql on daily basis using ORM and you just want to take a quick look at the table.

Oracle update - 1, :-)

My apologies to all db evangelists.

share|improve this question
add comment

2 Answers

If you just want to see the data in a table then do a select for that table in a query editor. That's the most basic operation wrt SQL. Using the table search with some "mysterious query" certainly does not help to accomplish that task. Search is, as the name implies, a search. Put the value you are looking for in the search field and let MySQL Workbench do the search for you. As easy as that.

If you want a mouse only approach then open the schema in the tree and right click on the table you want to see. A context menu appears and the first entry is the select (which takes the limit into account that is set in the preferences, to avoid pulling a potential million rows).

enter image description here

The old "Edit table data" was a very similar shortcut, but that uses the EDIT keyword to tell the editor that the result is editable. That was an intermediate addition as MySQL Workbench had no other way to know if that is the case. In the meantime the application can detect this automatically (a PK must exist, no aggregates, no joins etc.), so the EDIT keyword as well as the shortcut have been removed.

share|improve this answer
add comment

Right click on your table and choose select rows (first option)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.