Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

What is wrong here in following screen shot? enter image description here

I am trying solutions posted here and here to add a login

share|improve this question
3  
I would guess you are connected to SQL 2000 instance. Please verify the output of SELECT @@VERSION –  Shawn Melton Sep 11 '13 at 7:00
add comment

closed as off-topic by Jon Seigel, RolandoMySQLDBA, Max Vernon, Mark Storey-Smith, Michael - sqlbot Nov 24 '13 at 22:02

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Too localized - this could be because your code has a typo, basic error, or is not relevant to most of our audience. Consider revising your question so that it appeals to a broader audience. As it stands, the question is unlikely to help other users (regarding typo questions, see this meta question for background)." – Jon Seigel, RolandoMySQLDBA, Max Vernon, Mark Storey-Smith, Michael - sqlbot
If this question can be reworded to fit the rules in the help center, please edit the question.

2 Answers

up vote 1 down vote accepted

Are you 100% sure that this is SQL Server 2008? This behavior suggests SQL Server 2000.

The SQL Server 2000 syntax was

EXEC sp_addlogin 'recovery', 'ThePassword';
GO

Try that. If that works, when you get into the server check the compatibility level of all your databases in addition to running select @@VERSION.

share|improve this answer
add comment

The screenshot looks strange. First of all, SQLCMD don't work with SQL Server 2000. Among this, parameter -s means colseparator and not a server name. For servername usage the parameter -S need to be specified.

I tried the script like yours on SQL Server 2005 and 2008 and it works fine. enter image description here

Additional information according to SQLCMD usage can be found here:

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.