Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

Version SSIS 2012. Package was originally 2005 ver. Package on file system.

DB Engine / Agent on Host 1, SSIS on Host 2.

Execution from Host 2 runs successfully. Execution from Host 1 gives the error in the question subject. Saw this post, but engine and agent are installed on Host 1. Has anyone seen this? Google returns no results when searching on the exact error (subject line is exact, wording is odd in the error message).

Thank you!

share|improve this question
1  
I think Microsoft stopped proofreading error messages before they ship. I've seen more and more questionable ones lately in recent versions. –  Jon Seigel Sep 12 '13 at 21:27
1  
@billinkc: Interesting. So the question is what is the component "send successful email"? lol –  Jon Seigel Sep 12 '13 at 21:38
1  
On Host 2, you have the packages on the package file system. There you open SSMS, connect to IS and run package fine. Host 1, you connect to Host 2 to perform same actions and then it tilts? –  billinkc Sep 12 '13 at 21:39
1  
@JonSeigel I think it is raising the Name of assigned executable. Eric gets a +1 for not leaving things with default names ;) –  billinkc Sep 12 '13 at 21:40
1  
I need to leave momentarily but my theory for you is that the local machine is creating a call to the local dtexec.exe with the remote location of the file. Installation of the Integration Services component will probably make the problem go away. My other theory involves multiple SQL Server flavors on the box and the wrong dtexec is being picked –  billinkc Sep 12 '13 at 21:43
show 10 more comments

3 Answers

up vote 3 down vote accepted

SSIS 2012 components had to be installed on Host 1 to resolve the issue.

*If anyone knows of a way to resolve this without installing SSIS 2012 components where they aren't intended, please post and I'll accept your answer.

share|improve this answer
1  
Since the other question was tagged with 2005, presumably the behaviour has changed since then. –  Jon Seigel Sep 12 '13 at 21:47
add comment

I received the same error, but with the name of one of my job steps in place of ‘send successful email’. What worked for me was to restart Agent after adding my environment variable to the new server. Stupid, but it worked.

share|improve this answer
add comment

Please check out

  1. If integration Services are running
  2. If you are running package in same version on of SQL SERVER

--This should solve

share|improve this answer
    
This should be a comment. –  ypercube Jan 24 at 11:36
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.