Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

Installing 11gR2 on Oracle Linux 6.4. System is a desktop used by one developer. It's on DHCP. Hostname is similar to ip-t3400-1547.mydomain.local

Please note I have no issues installing this software on systems with fixed IP address, where the hostname is a solid alphanumeric string (no dashes).

I am loosely following:

I've installed the package oracle-rdbms-server-11gR2-preinstall, which takes care of many pre-install tasks. I've set SELinux to permissive. Quote from /home/oracle/.bash_profile:

export ORACLE_BASE=/u01/app/oracle
export ORACLE_SID=joe
export ORACLE_UNQNAME=joe
export ORACLE_HOSTNAME=ip-t3400-1547
umask 022

"joe" is the owner of the machine, so I'm using his name as the SID (real name edited for privacy). Please note that everything described below happens with or without ORACLE_UNQNAME being set here.

I select Server Class, Single Instance, Advanced Install, Enterprise Edition, General Purpose configuration type, then:

Global database name: joe
Oracle Service Identifier: joe

The above parameters, and the variables in .bash_profile, are different when installing on a system with a fixed IP address. In that case, I set ORACLE_HOSTNAME to the actual hostname of the machine (e.g.: dbserver13.mydomain.local), ORACLE_UNQNAME to the hostname (dbserver13), and SID same as UNQNAME (dbserver13). Works great.

I cannot do that on the DHCP-based workstation, because our naming convention includes the dash character in the hostname, which is not accepted by the installer for all those parameters.

I believe this difference is what causes the installer to fail, but I can't figure out an alternative.

I have tried to add "joe" and "joe.mydomain.local" to /etc/hosts, on the loopback entry (beginning with 127.0.0.1) but it makes no difference.

Character Sets: Unicode. Select Use Database Control, notifications disabled.

Some pre-requisite packages fail the check, but this is fine.

The installer keeps chugging along, then towards the end it throws this warning:

enter image description here

Enterprise manager configuration succeeded with the following warning -

Error starting Database Control. Please execute the following command(s).

1) Set the enrvironment variable ORACLE_UNQNAME to Database unique name

2) /u01/app/oracle/product/11.2.0/dbhome_1/bin/emctl start dbconsole

The problem is, I have that variable set already. It makes no difference.

As a result, the installer only asks me to run one post-install script, instead of the usual two scripts. The Web UI doesn't seem to work.

I am obviously doing something wrong.

How should I choose all those database names and SIDs and whatnot, in a way that allows me to install 11gR2 on a DHCP-based desktop?

share|improve this question
    
What is the result of ping "$ORACLE_HOSTNAME" command? –  kubanczyk Sep 24 '13 at 20:33
add comment

1 Answer

up vote 1 down vote accepted

you must edit bash-profile then install oracle database . in that you can set oracle_home and oracle_sid and etc . i have similar mistake and resolve it with edit bash-profile in oracle user to real and correct values at the end , you can refer to this article , it is useful

http://www.oracle-base.com/articles/11g/oracle-db-11gr2-installation-on-oracle-linux-6.php

share|improve this answer
    
Right, that one would work. I've found an algorithm meanwhile that works 100%, and mine even works on systems on DHCP, with a changing IP and hostname. It's pretty similar to the one you've linked, with some extra twists. –  Florin Andrei Oct 15 '13 at 0:32
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.