Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

My website (a Magento store) runs perfectly fine most of the time, until at some point MySQLd gets hammered with a few more INSERTs than normal, and then locks up. I run MySQL on Linodes with Debian 7.0 and ext4 on DRDB (for failover).

When it locks up, no queries are passed through and all activity is halted. I then SSH into the machine and see that the load is at 0.00, and the mysqld process itself is in Sl mode. I can't find any dead or zombie processes. I also tried to issue SHOW FULL PROCESSLIST; which just displayed that some INSERTs were waiting.

Where can i start to find out the issue of this? Can it be related to DRBD or ext4 somehow? Can it be the issue of some mysqld setting hitting the ceiling?

This is my custom my.cnf: https://gist.github.com/jonathanselander/0c4f22ba06b613083d3c

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.