Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

I have a PostgreSQL 9.3.1 DB Server running in Windows 7 Ultimate. I have checked the file postgresql.conf and this lines are uncommented:

listen_addresses="*"
port=5432

And this is the configuration at pg_hba.conf file:

# TYPE  DATABASE        USER            ADDRESS                 METHOD

# IPv4 local connections:
host    all             all             127.0.0.1/32            md5
host    all             all             127.168.1.0/24          md5

# IPv6 local connections:
host    all             all             ::1/128                 md5

# Allow replication connections from localhost, by a user with the
# replication privilege.
#host    replication     postgres        127.0.0.1/32           md5
#host    replication     postgres        ::1/128                md5

Apparently all is fine but if I run the command netstat -an I don't see the port 5432 open to any host unless this line:

0.0.0.0:5432 

means that. The problem is I can't connect from any PC in subnet 192.168.1.x and the message says PostgreSQL isn't installed on the PC or it doesn't listen. I have disable any firewall in all PC looking for a solution but can't. Can any help me to find the problem here?

UPDATE

This is the error I'm getting:

enter image description here

share|improve this question

closed as off-topic by dezso, ypercube, RolandoMySQLDBA, Max Vernon, RLF Nov 4 at 17:51

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Too localized - this could be because your code has a typo, basic error, or is not relevant to most of our audience. Consider revising your question so that it appeals to a broader audience. As it stands, the question is unlikely to help other users (regarding typo questions, see this meta question for background)." – dezso, ypercube, RolandoMySQLDBA, Max Vernon, RLF
If this question can be reworded to fit the rules in the help center, please edit the question.

    
Please post the exact error message! –  Milen A. Radev Oct 16 '13 at 14:10
    
@MilenA.Radev basically the error looks like the one showed in the picture (see edition) but pointing to my local address 192.168.1.101 and port 5432 –  Reynier Oct 16 '13 at 15:06
    
0.0.0.0:5432 does indeed mean that it's listening on all addresses at port 5432. –  Colin 't Hart Oct 16 '13 at 15:18
1  
And this is from the same client PC that you've tried to connect using your PG client (looks like PGAdmin)? –  Colin 't Hart Oct 16 '13 at 16:12
1  
There is a typo in the pg_hba.conf: 127 should be 192 on the second uncommented line -- assuming this line is meant to allow password connections from the LAN. But this should give a different error than the one you report. –  Colin 't Hart Oct 16 '13 at 16:14

1 Answer 1

i have the same problem. I disabled all my third party antiviruses and firewalls and reinstall PostgreSQL again and its now working fine... :)

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.