Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

I am trying to access my database table through phpmyadmin where the database has around 20 tables in it. When I try accessing three particular tables it is showing Gateway error on phpmyadmin. But the rest of the database table are working properly and also my software is working properly other than where it needs those particular tables. When I tried to repair table it exactly got stuck in the tables which seem to have problem. I do not know what to do other than reporting it to my hosting provider.

share|improve this question
    
You shouldn't be trying to troubleshoot your server with phpmyadmin. What happens when you use the command line client? You should get much more useful information that way. –  Michael - sqlbot Oct 19 '13 at 15:01
    
I tried repairing table in command line only. It got stuck in the seems-to-be-faulty table –  Venky Oct 19 '13 at 15:11
    
"It got stuck" ... what does that mean? Does SHOW FULL PROCESSLIST? show something interesting? –  Michael - sqlbot Oct 19 '13 at 16:33
add comment

1 Answer

I an answering my own question :

I solved this issue by restarting the network with the following command

$ sudo /etc/init.d/networking restart

and changed the folder permission.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.