Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

I can login using this command: sqlplus test/test@127.0.0.1:1521/local But not this one: (where 192.168.0.240) is my IP sqlplus test/test@192.168.0.240:1521/local

I am absolutely sure that my ip address (server's adress) is 192.168.0.240. So why am I getting the following error? ORA-12541: TNS:no listener

I get a connection timeout when trying to connect from other computers.

lsnrctl statusgives me the following:

Connecting to (DESCRIPTION=(ADDRESS=(PROTOCOL=IPC)(KEY=EXTPROC1521)))
STATUS of the LISTENER
------------------------
Alias                     LISTENER
Version                   TNSLSNR for 32-bit Windows: Version 11.2.0.1.0 - Produ
ction
Start Date                23-OCT-2013 15:27:35
Uptime                    0 days 21 hr. 37 min. 20 sec
Trace Level               off
Security                  ON: Local OS Authentication
SNMP                      OFF
Listener Parameter File   C:\app\pc2\product\11.2.0\dbhome_2\network\admin\liste
ner.ora
Listener Log File         c:\app\pc2\diag\tnslsnr\pc2-PC\listener\alert\log.xml
Listening Endpoints Summary...
  (DESCRIPTION=(ADDRESS=(PROTOCOL=ipc)(PIPENAME=\\.\pipe\EXTPROC1521ipc)))
  (DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=127.0.0.1)(PORT=1521)))
Services Summary...
Service "CLRExtProc" has 1 instance(s).
  Instance "CLRExtProc", status UNKNOWN, has 1 handler(s) for this service...
Service "local" has 1 instance(s).
  Instance "local", status READY, has 1 handler(s) for this service...
Service "localXDB" has 1 instance(s).
  Instance "local", status READY, has 1 handler(s) for this service...
The command completed successfully
share|improve this question
1  
(DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=127.0.0.1)(PORT=1521))) --> it's only listening on 127.0.0.1. Check your C:\app\pc2\product\11.2.0\dbhome_2\network\admin\liste ner.ora edit the host = <ip> part or add one. and do lsnrctl reload –  Munchi Oct 24 '13 at 11:14
    
i edited the settings and added another host 192.168.0.240 i can now connect using that address but only from the sever, not other machines on the same subnet. Ping succeeds but db connection fails. –  Anthony Oct 24 '13 at 12:01
    
it was a firewall issue. I thought the port should be open by default on private networks, or automatically enabled by the installer (like most other programs). Apparently it was being blocked, and I never got a notification from windows firewall. What a waste of time! –  Anthony Oct 24 '13 at 12:16
1  
You mean security is a waste of time? :P GG –  Munchi Oct 24 '13 at 12:36
    
No, I'm just saying it took me much more time than it should have. Maybe I ignored the firewall dialog (the one with keep blocking/unblock buttons) when it showed up the first time. –  Anthony Oct 24 '13 at 14:44

2 Answers 2

up vote 1 down vote accepted
(DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=127.0.0.1)(PORT=1521)))

You have the localhost ip in the listener.ora (127.0.0.1), change this or add another line with the NIC ip.

share|improve this answer

Usually, its an issue with the firewall. Please make sure that your firewall is set to Off and then try to reconnect from another computer. I had the same problem and resolved it by doing the same.

share|improve this answer
2  
this question already has an accepted answer and it was not firewall related –  Jack Douglas Mar 26 at 10:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.