Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

I'm trying to install mongodb as service on a machine running Windows Server 2008R2. I'm getting this message in the command prompt:

The service is not responding to the control function. More help is available by typing NET HELPMSG 2186.

I have tried either removing --install option from config file/adding this option to the execution script, using script like

mongod --config mongod.config --service --reinstall

There is unresolved issue at https://jira.mongodb.org/browse/SERVER-5115 describing the same problem.

Is it possible to make this work?

share|improve this question

migrated from stackoverflow.com Oct 25 '13 at 15:51

This question came from our site for professional and enthusiast programmers.

2  
Have you tried using an absolute path for the config file, e.g. mongod --config "C:\mongodb\bin\mongod.config" --install? –  mnemosyn Oct 14 '13 at 12:37
1  
@mnemosyn That helped! –  lexeme Oct 14 '13 at 12:53
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.