Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

I am trying to connect my MySQL RDS from EC2. Under security groups I have made sure permissions are in place.

$ mysql -h xxx.xyz.ap-southeast-1.rds.amazonaws.com -P 3306 -p
Enter password:

I am sure password is correct; because i reset it using AWS console. I am getting following error:

 Access denied for user 'root'@'ip-xx-xxx-xxx-xxx.ap-southeast-1.compute.internal' (using password: YES)

Looks like

share|improve this question
    
You say you have made sure permissions are in place; does that mean you added the EC2 instance's security group the the RDS instance's security group? –  Willem Renzema Oct 27 '13 at 5:49
    
Yes Willem.. And I feel that will take care of allowing tcp connection between EC2 and RDS.. And root password should also be fine.. I guess that permissions at mysql level is creating problem ! –  Deepak Oct 27 '13 at 5:56
    
As part of the setup process you are asked to choose a master username. Are you able to connect with that? –  Willem Renzema Oct 27 '13 at 6:03
    
@Deepak what Willem is saying in the above comment is that there is no "root" user in RDS unless you chose "root" as the master username or manually created an account with that name. –  Michael - sqlbot Oct 27 '13 at 21:52
add comment

1 Answer

up vote 1 down vote accepted

I am 99% sure that Amazon RDS does not give you a 'root' access. i.e. You can't create a user as 'root'@'localhost' or 'root'@''.

Can you confirm user you have used while launching Amazon RDS instance? and make sure that Password matches with user created.

share|improve this answer
    
Security group does not matter here as you are able to connect to Amazon RDS and "Access denied ...." is authentication error due to wrong credentials specified while connecting to RDS/ –  Mahesh Patil Oct 29 '13 at 12:02
    
I agree Mahesh it is not a problem of security group. Is there any way I can know this master user I used ? I tried whatever users I could think of. –  Deepak Oct 29 '13 at 13:36
    
I have tried in Amazon RDS to find out Master user credentials, but could not find a useful link. I suggest you to terminate this instance and launch a new instance and note down Master user credentials ... otherwise contact Amazon RDS support and ask for details –  Mahesh Patil Oct 31 '13 at 4:59
    
right now the only way to find master user was using RDS tool.. which worked for me. –  Deepak Oct 31 '13 at 9:14
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.