Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

I installed MongoDB under Ubuntu server and when inter to MongoDB shell i got this error and warnings.

MongoDB shell version: 2.4.7
connecting to: test
Server has startup warnings: 
Sun Oct 27 09:58:39.360 [initandlisten] 
Sun Oct 27 09:58:39.360 [initandlisten] ** NOTE: This is a 32 bit MongoDB binary.
Sun Oct 27 09:58:39.360 [initandlisten] **       32 bit builds are limited to less than 2GB of data (or less with --journal).
Sun Oct 27 09:58:39.360 [initandlisten] **       Note that journaling defaults to off for 32 bit and is currently off.
Sun Oct 27 09:58:39.360 [initandlisten] **       See http://dochub.mongodb.org/core/32bit
Sun Oct 27 09:58:39.360 [initandlisten] 

how I hide this warnings Thanks

share|improve this question

migrated from stackoverflow.com Oct 27 '13 at 16:42

This question came from our site for professional and enthusiast programmers.

1 Answer 1

up vote 3 down vote accepted

I don't believe there is a way to suppress only that warning, but you can always start your mongod instance with the --quiet flag.

--quiet Runs the mongod instance in a quiet mode that attempts to limit the amount of output. This option suppresses:

  • output from database commands, including drop, dropIndexes,
  • diagLogging, validate, and clean. replication activity. connection
  • accepted events. connection closed events.

Reference - http://docs.mongodb.org/manual/reference/program/mongod/#cmdoption--quiet

So when you use this flag, you are actually disabling quite a lot of useful information. As you can see from the content of the warning, using the 32bit version will seriously limit the amount of data you will be able to store. I think you should consider upgrading to the 64bit version.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.