Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

so i'm trying to installl mytop to monitor the database

i'm following this instruction : http://www.sohailriaz.com/how-to-install-mytop-a-top-clone-for-mysql/

when i try to install it with yum i get this :

yum -y install mytop 

    --> Finished Dependency Resolution
    Error: Package: perl-DBD-MySQL-4.013-3.el6.x86_64 (base)
               Requires: libmysqlclient.so.16()(64bit)
    Error: Package: perl-DBD-MySQL-4.013-3.el6.x86_64 (base)
               Requires: libmysqlclient.so.16(libmysqlclient_16)(64bit)
     You could try using --skip-broken to work around the problem
     You could try running: rpm -Va --nofiles --nodigest

i have mysql 5.5.x installed and apparently

libmysqlclient.so.16 is provided by MySQL 5.1 packages

i'm certinly not going to downgrade to 5.1 .

so is there anyway around this without downgrade or any majore change ? if not is there any other more up to date , free , similar tool ?

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.