Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

After checking the box I noticed that queries that would timeout after 30 seconds would complete execution.

The TechNet article says "AWE is not required and cannot be configured on 64-bit operating systems."

So did checking the box do anything?

SQL Server 2008 R2 / Version 10.52.4000.0

share|improve this question
add comment

1 Answer

For 64 bit OS, you dont need AWE and even enabling AWE using sp_configure awe enabled has no meaning.

Refer to Great SQL Server Debates: Lock Pages in Memory by Jonathan Kehayias :

In 64-bit SQL Server, the SQL Server account still requires the Lock Pages in Memory permission in order to be able to allocate locked pages, via AllocateUserPhysicalPages(), but there are a couple of big differences:

The underlying reliance on AWE-mapped memory is removed. You do not need AWE in 64-bit SQL Server; the awe enabled sp_configure option has no meaning. The continued use of the same AWE API function is purely to ensure that the allocated pages are locked.

Memory allocated via AllocateUserPhysicalPages() can be used for both the data cache and plan cache. In 64-bit SQL Server, the plan cache is no longer allocated separately (it now uses stolen pages from the buffer pool)

The memory allocations for AWE in 32bit use the AllocateUserPhysicalPages() API. The memory allocations for lock pages in 64bit use the same API, but they aren't using AWE because the VAS in a 64-bit process is 8TB for user mode space and it doesn't require special mappings through AWE.

Queries timing out has least to do with AWE. There might be missing indexes, outdated stats, poorly configured memory settings and many other stuff that can lead to queries timing out.

What specific version of sql server are you running (along with patch level) ?

share|improve this answer
    
MSSQL 2008 R2 10.52.4000.0 –  Jon.ee Nov 14 '13 at 14:46
    
I read the same article prior to posting; however, I am still not sure as to why there would be SQL Timeouts before but not after. –  Jon.ee Nov 14 '13 at 16:02
    
@Jon.ee Have you tried disabling it (revert it back) and then run profiler with user error message ticked and see why your queries are timing out ? AWE has no effect in 64 bit systems. –  Kin Nov 14 '13 at 16:42
    
I have unchecked the box. So I am still unsure as to why enabling AWE resolved the SQL execution timeouts and now I am unable to recreate the problem. –  Jon.ee Nov 14 '13 at 16:58
    
@Jon.ee that is exactly my point. you just happened to click AWE option and it you thought it worked, but in-fact AWE has no effect on 64 bit systems and definately is not the cause of your query timeouts. As I said, you can run a profiler to see whats going on or use XEvents, DMV's etc to find out the actual root cause. –  Kin Nov 14 '13 at 17:06
show 4 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.