Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

Some times ago I have done backup my MS SQL Server database and then I restore it (on other computer and server). Today I would make just like two weeks ago. But when I choose file to restore from devise I see error:

TITLE: Microsoft SQL Server Management Studio

An exception occurred while executing a Transact-SQL statement or batch. (Microsoft.SqlServer.ConnectionInfo)


ADDITIONAL INFORMATION:

RESTORE HEADERONLY is terminating abnormally. (Microsoft SQL Server, Error: 3013)

For help, click: http://go.microsoft.com/fwlink?ProdName=Microsoft+SQL+Server&ProdVer=10.50.2500&EvtSrc=MSSQLServer&EvtID=3013&LinkId=20476


BUTTONS:

OK

I am really confused, because I done everything just like two weeks ago. Of course, I searched in Internet how to solve the problem but it didn't help me.

share|improve this question
    
When you say "Some times ago I have done backup my MS SQL Server database " - How long ago? What version of SQL Server did you take the backup from? Is this the same exact backup file you restored from 2 weeks ago? Same exact destination server? 3013 errors should give you more info if you look in the SQL Server error log or if you restore it with a restore script. Can you provide more details? My guess is either a version mismatch or a corrupt backup file, more info will help there. –  Mike Walsh Nov 18 '13 at 16:51
4  
Try doing this: restore verifyonly from disk = 'wherever you stored your backup file'; and let us know what the output is. –  Thomas Stringer Nov 18 '13 at 16:55
    
I took backup from SQL Server 2008 R2 and restore it also on SQL Server 2008 R2 so the version is the same. When I execute query which will restore database I get: Read on "C:\...\database.bak" failed: 13(failed to retrieve text for this error. Reason: 15105) Msg 3013, Level 16, State 1, Line 1 VERIFY DATABASE is terminating abnormally. –  Thomas Nov 18 '13 at 17:11
    
Did permissions for the user running the background change? The user may not have permission to read from that directory. Run SSMS as an administrator or adjust rights, and try the Verify again. –  Sean Long Nov 18 '13 at 17:50
    
I run SSMS as administrator - the same error. Maybe there is problem with rights, as you said. Could you tell me how can I check this and how adjust rights? –  Thomas Nov 18 '13 at 18:08
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.