Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

I'm playing around with the USING clause in RMAN, but cannot seem to get it to work. Here is my RMAN command:

rman target username/password @${RMAN_DIR}/backup.rman using "db1"

When I run that (with double quotes, single quotes, no quotes, using a parameter), I get the error below.

I'm on Oracle 11.2.0.4 on Linux.

Argument     Value          Description
-----------------------------------------------------------------------------
target       quoted-string  connect-string for target database
catalog      quoted-string  connect-string for recovery catalog
nocatalog    none           if specified, then no recovery catalog
cmdfile      quoted-string  name of input command file
log          quoted-string  name of output message log file
trace        quoted-string  name of output debugging message log file
append       none           if specified, log is opened in append mode
debug        optional-args  activate debugging
msgno        none           show RMAN-nnnn prefix for all messages
send         quoted-string  send a command to the media manager
pipe         string         building block for pipe names
timeout      integer        number of seconds to wait for pipe input
checksyntax  none           check the command file for syntax errors
-----------------------------------------------------------------------------
Both single and double quotes (' or ") are accepted for a quoted-string.
Quotes are not required unless the string contains embedded white-space.

RMAN-00571: ===========================================================
RMAN-00569: =============== ERROR MESSAGE STACK FOLLOWS ===============
RMAN-00571: ===========================================================
RMAN-00552: syntax error in command line arguments
RMAN-01009: syntax error: found "db1": expecting one of: "double-quoted-string, identifier, integer, single-quoted-string"
RMAN-01007: at line 2 column 1 file: command line arguments
share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

The Linux shell must be interpreting the double quotes before the command gets to rman. Either escape the double quotes:

rman target username/password @${RMAN_DIR}/backup.rman using \"db1\"

or enclose the command in single quotes to prevent the shell from messing with it:

rman target username/password @${RMAN_DIR}'/backup.rman using "db1"'

In the latter case you will have to leave the environment variable outside the quoted command as you do want the shell to expand it.

share|improve this answer
    
Escaping the quotes worked, thank you! –  unclenevin Nov 19 '13 at 18:47
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.