Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

I'm using Oracle database and I've created a test table "Table1" with a varchar column "column1". I ran the following loop to add some rows:

BEGIN
    FOR i in 1..10 LOOP
        INSERT INTO TABLE1 (COLUMN1) 
        VALUES (i);
    END LOOP;
END;

If I run 'select count(*) from table1' I get '10' as my result. However, in SQL Developer, nothing shows up. I can add rows manually and commit them to the database(these appear in SQL Developer), but I can't seem to view the ones created in sqlplus command line. Why is that?

share|improve this question

1 Answer 1

up vote 2 down vote accepted

I see no COMMIT up there in your code. By default SQL*Plus autocommit is off. Data changes are not visible to other sessions until they are not commited.

share|improve this answer
    
Ah, thank you very much! I knew it had to be something simple –  Brett Porter Dec 27 '13 at 14:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.