Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

I need to duplicate a Oracle 11g Express Edition database from one computer to another computer.

I tried exp sys/password FULL=Y FILE=backup.dump (the idea is to do a imp on the other pc)

But it gaves me the following error:

EXP-00008: ORACLE error 12704 encountered
ORA-12704: character set mismatch
ORA-06512: at "SYS.DBMS_SERVER_ALERT_EXPORT", line 10
ORA-06512: at "SYS.DBMS_SERVER_ALERT_EXPORT", line 118
ORA-06512: at line 1

How can I make a full, complete backup with usernames, passwords, everything to be loaded into another host?

share|improve this question
    
What version of exp are you trying to use to do the export? –  Phil Jan 2 at 9:14
    
The character set and national character set of both db are the same? I have found some causes to that error here. Anyway you can try to import only your own schemas you need, or you can try to clone the db using RMAN, for example. –  Shaunyl Jan 2 at 14:37
    
I am using Export: Release 11.2.0.2.0 –  Fernando Jan 2 at 17:35
    
Which two dbs? I have that error when trying to make a backup, not even tried to restored it. Anyway... I am tring with RMAN now.. let's see if it works. –  Fernando Jan 2 at 17:37
    
Sorry, I misread your question. Anyway, doing some tests, in the log I get this text: Export done in UTF8 character set and UTF8 NCHAR character set server uses AL32UTF8 character set (possible charset conversion). What log text do you get? –  Shaunyl Jan 2 at 17:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.