Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

I created an SSIS package in Visual Studio 2008 and deployed it to SQL Server 2012 by using Integration Services Catalogs. When I run the package from BIDS it completes successfully. When I schedule the package to run using a job the execution of the job fails (sometime randomly) with the following message:

Environment reference Id: NULL. Description: Timeout expired. The timeout period elapsed prior to completion of the operation or the server is not responding. Source: .Net SqlClient Data Provider

I tried to add retry for this step and at second retry it works fine. I don't know the reason, this job worked for 2 years with no issues.

share|improve this question
    
Do you running this ssis package in BIDS on same box when you have it scheduled as sql job ? Do you using same sql account for sql agent and when you running package manually ? –  Kuba Miazek Jan 5 at 9:40
    
the problem is :the same scheduled job fail somtime(not always).. randomly diffrent behavior with same Box.. –  abianari Jan 5 at 13:49
    
So... maybe it is network issue not your etl issue. –  Kuba Miazek Jan 6 at 9:37
    
the ssiscatalog db and sql agent job which executes ssis Package are on the Same Machine. –  abianari Jan 6 at 9:52
1  
i add the index mentioed. and i will inform you if it does not retry or fail after 5 days Of Execution (beacaues it is nighly job and failed somtime) –  abianari Jan 8 at 5:03

1 Answer 1

up vote 0 down vote accepted

delete Unused Connection String(specially those have invalid connection string) search for child Package reference that are disable but has invalid references.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.