Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

I have installed SSRS 2008 R2 on Windows 2012 server. It is up and running. In the Configuration Manager, I have set it to point to remote Database on same network.

Then on my own PC (also on network) I open Report Manager website. I can see all reports fine. However, I get an error when attempting to run report. I then click on Datasource giving error and get this... enter image description here

I have checked the domain server and the server hosting SSRS is added. In SSRS Configuration Manager, the Authentication Type is Service Credentials, and Username is domain\SQLService. When I test the Database connection from here, all is ok.

Any ideas why this is not working? Looks like Kerberos is not the issue. Thanks.

share|improve this question
    
What makes you think Kerberos isn't the problem? Have you tried using this? microsoft.com/en-us/download/details.aspx?id=39046 –  Thomas Stringer Jan 7 at 18:34
    
I didn't think Kerberos is the issue when using Service Account? Anyway, I have installed Kerberos Configuration Manager on the server hosting SSRS. I then attempt to connect to the remote Database through this. I tried my own login and then tried sa but get this error... There was a permission issue accessing required services. Thanks –  k09 Jan 8 at 9:28
    
I ran this query on the old server(SSRS2005) I am migrating from: select auth_scheme from sys.dm_exec_connections where session_id=@@spid, and it returns SQL rather than Kerberos. Yet no issues with remote database from here. Also I ran setspn -l domain\serviceaccounton the domain controller and the new server is listed. –  k09 Jan 8 at 15:43
    
OK. Looks like issue with my account for some reason. Kerberos all ok but when I try setting credentials on DataSource to domain\serviceaccountI get permissions granted to mySSRSserver\Administrator are insufficient (rsaccessdenied). I do not know why it thinks I am using SSRS server admin login when logging in from my own PC?? Tested on other user pcs and works fine! –  k09 Jan 9 at 12:00
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.