Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

I have originally posted this thread on stackoverflow and after a comment I moved it here. The original post can be found here.

I have setup a typical Master-Slave replication scheme for my MySQL database. Up until now the topology is consisted from only one master and one slave node, both are using SSL to securely communicate with each other.

On Master node:

enter image description here

On the Slave node:

enter image description here

I have no error in the error.log on neither side, but when I change something on the Master node and then check the slave, the change is not replicated.

I followed this tutorial so I am pretty confident that my my.cnf are properly configured.

Is there any hints on what can be wrong in this setup?

share|improve this question
    
You've mis configured your slave. Please check the replication filters; Replicate_Do_DB: /var/lib/mysql/live01 ... –  eroomydna Jan 8 at 15:20
    
@eroomydna I have fixed that thank you for pointing it out, but the changes are still not propagated from master to slave. –  maxsap Jan 8 at 15:41
    
What actions did you take, how is the SHOW SLAVE STATUS\G output looking now? –  eroomydna Jan 9 at 9:36
    
@eroomydna It only contains /var/lib/mysql/live01 –  maxsap Jan 9 at 17:28
    
This is a filesystem path. Try only using only live01 as your argument. –  eroomydna Jan 9 at 17:29
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.