Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

How to copy PostgresSQL database from remote server to local PC without pg_dump (or pg_dumpall ?

Any format is good (plain text,sql,csv..)

I have NO root access to remote PostgresSql database and I had NO superuser rights! (Where is no pg_dump, pg_dump_all commands on remote server, I have no permission to use it)

I have *only*user and passw from remote PostgresSQL so I can connect and run READ queries from PostgreSQL database. (Simply put: I have only read permission)

I tried vaiuos software tools (Navicat,RazorSQl,....) but got message

can't read db shema, you have no permission. Copy aborted where is no such command on server:pg_dump)

I need to make a copy of it to my local PC! PostgreSQL database version 9.0.X Database is 100GB!

share|improve this question
    
pg_dump neither needs superuser nor root access to work. All you need is a regular login. –  a_horse_with_no_name Jan 16 at 18:22
    
""pg_dump neither needs superuser nor root access to work. All you need is a regular login."" -Thanx for reply . But maybe it is installed with errors or deleted on server! pg_dump and pg_dumpall dont work! –  Sinagerti Jan 16 at 19:41
3  
pg_dump is a client application. You can install it on any computer from which you have access to the database server. You ca download the Postgres ZIP archive, unzip it and run pg_dump without any further "installation" (works on Windows just as well as on Linux) –  a_horse_with_no_name Jan 16 at 19:43
    
Thnx for reply! pg_dump somehow have no access to database!Its not working ! I have tried intsall variuos versions of PosgresSql but no luck! But when I use SQL queries command line or GUI i can read hole database! Whats why is problem to use pg_dump. –  Sinagerti Jan 17 at 7:17
    
Then you are probably connecting with a different user in pg_dump than you use in your gui or the commandline. –  a_horse_with_no_name Jan 17 at 7:29
show 2 more comments

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.