Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

I'm running a database restore on a backup file that was created up on a clients server, the backup file has been moved to our server (same SQL version 2008 R2) and I'm getting the following error after the T-SQL has been running for nearly 7 minutes:

TSQL:

RESTORE DATABASE [Charms_OrangeGrove]   
FROM    DISK = N'S:\MSSQL10_50.MSSQLSERVER\MSSQL\Backup\Charms_OrangeGrove_290114.bak'   
    WITH  MOVE N'CharmsData_dat'   
          TO N'S:\MSSQL10_50.MSSQLSERVER\MSSQL\DATA\Charms_OrangeGrove.mdf',    
          MOVE N'CharmsData_log' 
          TO N'S:\MSSQL10_50.MSSQLSERVER\MSSQL\DATA\Charms_OrangeGrove_Log.ldf'

Error:

Msg 3203, Level 16, State 1, Line 1
Read on "S:\MSSQL10_50.MSSQLSERVER\MSSQL\Backup\Charms_OrangeGrove_290114.bak" 
    failed: 38(failed to retrieve text for this error. Reason: 15105)
Msg 3013, Level 16, State 1, Line 1
RESTORE DATABASE is terminating abnormally.
share|improve this question

1 Answer 1

It looks like you are having a disk read problem or perhaps a corrupted backup.

I would try

a. Run RESTORE VERIFYONLY FROM DISK =  
        N'S:\MSSQL10_50.MSSQLSERVER\MSSQL\Backup\Charms_OrangeGrove_290114.bak'
b. If it comes up clean try copying it to a different location 
        (preferably a different drive on different physical hardware)

Here is a link where someone had a similar problem. It has some additional steps he tried and mentions that he had a hardware problem.

http://social.msdn.microsoft.com/Forums/sqlserver/en-US/2a127a18-dfd0-4668-afc4-f5eb497f4977/sql-server-2008-restore-fails-msg-3203?forum=sqldisasterrecovery

share|improve this answer
    
Thanks for your suggestion, I tried the VERIFYONLY method but received an almost identical error message. I'm going to backup the database again and try with another file. –  Mark Collins Jan 30 at 14:03
    
Your backup was probably corrupt then. Either that or the location has problems. If your next backup has problems as well I would have the location checked. –  Kenneth Fisher Jan 30 at 14:18
    
The new backup worked straightaway! Strange that the SQL Server I used to create the first backup didn't report an issue initially? Ah well, problem solved anyway thanks. –  Mark Collins Jan 30 at 14:35
    
It's generally suggested that you test your backups if not every time then at least occasionally. Because of IO problems you will occasionally (hopefully not to often) get backups that are corrupt and unusable. –  Kenneth Fisher Jan 30 at 14:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.