Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

Yesterday I installed PostgreSQL 9.0 on Windows XP, and after the installation the DB was running. After booting the system this morning, the data base server did not start automatically.

How do I configure Windows XP to start the postgresql demon after each boot/reboot? (I'm a Unix guy, and guess that's easy for someone knowing Windows.)

share|improve this question
    
Good question but might actually be geared towards SF since it's really a matter of the services of the system, not of something dba specific. –  jcolebrand Jan 12 '11 at 17:59

1 Answer 1

up vote 3 down vote accepted

Here's a couple things to check:

  1. I believe the Windows PostgreSQL installer has an option you have to check saying you want to run PostgreSQL as a service. Make sure you used this option when you did your install.

  2. Make sure the service is set to start automatically.

    • Start->Control Panel->Administrative Tools->Services
    • Find the service (should be named something like postgresql-9.0)
    • Make sure the Startup Type is set to Automatic
share|improve this answer
    
Thanks for the answer. I'm looking into it now (the problem is my non-English Windows installation). –  j.p. Jan 13 '11 at 9:18
    
The service was already set to start automatically, but there was a problem with the user (postgresql)/the password, which I solved by setting both to the correct values. Thanks again. –  j.p. Jan 14 '11 at 16:35
    
@jug: That was gonna be my next suggestion, glad you got it working! –  BenV Jan 14 '11 at 16:49
    
@BenV: Somehow my password gets lost after every 2nd reboot (I switch off my development PC every night), so that I have to reinsert the correct password as admin again and again. Do you happen to have a clue what's going on? (Thanks in advance) –  j.p. Jan 27 '11 at 12:28
    
@jug: Please post this as a new question - that way more people than just me will see it. –  BenV Jan 27 '11 at 14:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.