Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a database in MS SQL2005 that I can not backup.
Whenever I try to create a backup of the selected database through SQL Mgm studio I get this error:

The Backup of full-text catalog in not permitted because is not online

This database was crated by detaching another database, copying the data and log files, and attaching the copies as a new database. How I can make my full-text catalog be online again. I also tried to set USE FULL TEXT SEARCH to false but without success.

Here is my errorenter image description here

share|improve this question
up vote 4 down vote accepted

There is a MS KB article on it which say it happens because

  • The full-text catalog folder is either deleted or corrupted.
  • You did not enable the database for full-text indexing.
  • The database is restored from a Microsoft SQL Server 2000 database backup. Therefore, the folder of the full-text catalog in the database does not exist on the server where you restore the database.
  • The instance of SQL Server 2005 that you are running was upgraded from SQL Server 2000. However, the full-text search service cannot be accessed during the upgrade.
  • The database is attached from somewhere. However, you specify the incorrect location for the full-text catalog folder during the attachment.

The article also has a "workaround" section

share|improve this answer

When you copied the database and attached did you also copy the full text data to another location, then change the locations of the full text indexes?

It sounds like both of the databases are pointing to the same full text location (or if you copied the database to another server you didn't include the full text data).

Depending on how this is answered will determine the next steps to take.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.