Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

I'm trying to enable Text Search in my DB2 instance. I'm running this command:

# /opt/ibm/db2/V10.5/instance/db2iupdt db2inst1 -j "TEXT_SEARCH,db2j_db2inst1,55000"

I get this error:

DBI1011I  An invalid argument was entered for the db2iupdt command.

Explanation:

You can use the db2iupdt command to update a DB2 instance to a higher
level within a release, convert a DB2 instance to a DB2 pureScale
instance, or manage DB2 members or cluster caching facilities (CFs) of a
DB2 pureScale instance.

This message is returned when the db2iupdt command is invoked with
incorrect or missing parameters.

User response:

Enter the command again using valid parameters.


   Related information:
   db2iupdt - Update instances command
   Updating an instance to a higher level within a release using the
   db2iupdt command
   Updating an instance to a DB2 pureScale instance with the db2iupdt
   command
   Dropping a member or cluster caching facility
   Adding new members or an additional cluster caching facility

DBI1011I documentation just says there's something wrong with the parameters. I'm not seeing anything obviously wrong with them when looking at the documentation for db2iupdt.

I'm running DB2 10.5:

$ db2licm -l
Product name:                     "DB2 Advanced Workgroup Server Edition"
License type:                     "CPU Option"
Expiry date:                      "Permanent"
Product identifier:               "db2awse"
Version information:              "10.5"
Max amount of memory (GB):        "128"
Enforcement policy:               "Soft Stop"

How do I successfully enable Text Search in my DB2 instance?

share|improve this question
add comment

2 Answers

According to the syntax diagram at http://pic.dhe.ibm.com/infocenter/db2luw/v10r5/topic/com.ibm.db2.luw.admin.cmd.doc/doc/r0002060.html, you should enclose the text search options in double quotation marks:

-j "TEXT_SEARCH,db2j_db2inst1,55000"

Don't forget to escape them in the shell.

share|improve this answer
    
Unfortunately, I get the same error with /opt/ibm/db2/V10.5/instance/db2iupdt db2inst1 -j "TEXT_SEARCH,db2j_db2inst1,55000". I've edited the question to reflect this. –  Leons Feb 22 at 0:47
    
Also, same error with shell-escaped /opt/ibm/db2/V10.5/instance/db2iupdt db2inst1 -j \"TEXT_SEARCH,db2j_db2inst1,55000\" –  Leons Feb 22 at 0:53
1  
Shouldn't the instance name come after the option? –  mustaccio Feb 22 at 15:02
    
You're right, that's the issue. On Linux, the instance name has to be the last thing on the command line. The Information Center is pretty confusing on this: pic.dhe.ibm.com/infocenter/db2luw/v10r5/… –  Leons Mar 17 at 19:25
add comment
up vote 0 down vote accepted

On Linux, the instance name has to be the last thing in the db2iupdt command:

# /opt/ibm/db2/V10.5/instance/db2iupdt -j "TEXT_SEARCH,db2j_db2inst1,55000" db2inst1
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.