Sign up ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

I am using SSMS 2012. I am working with .PRC, .TAB, and .UDF files. I added these file extensions to SSMS so that it would treat them like .SQL files already via Tools > Options > Text Editor > File Extension, but recently SSMS has stopped recognizing these files (e.g. won't show them with color coding or allow me to run them against a database). Funnily enough when I remove a file extension from a file it then recognizes them because it has "Map extensionless files to SQL Query Editor" checked.

Does anyone know what the problem might be?

share|improve this question
Try adding it without the leading period (.): – Shawn Melton Feb 24 '14 at 16:17
None of them have been added with the leading period (SSMS doesn't let you add one with e leading period). – tuseau Feb 24 '14 at 16:29
So it worked for some time, then it stopped working? Anything happen at that time (e.g. did you install a new version of Management Studio, or uninstall anything, or install Visual Studio or SQL Server Data Tools, etc.)? What is your version of Management Studio (Help > About) and are you saying it's broken in both 2012 and 2008, or only one? – Aaron Bertrand Feb 24 '14 at 16:33
This should have been fixed with SP1 (which you have applied to your client tools). See if the manual steps described here work... also see this Connect item. – Aaron Bertrand Feb 24 '14 at 18:47
Thanks, the registry keys seemed to work for me today. I'm sure I had tried them already. Seems to be some temperamental behavior with SSMS. – tuseau Feb 25 '14 at 12:14

1 Answer 1

up vote 1 down vote accepted

According to this Connect item, this bug was fixed in Service Pack 1.

However, if the issue persists, you can try this convoluted workaround posted over at SQLServerCentral by Marios Philippopoulos:

OK, got it to work with help from

Opened regedit.exe as Administrator.


On [HKEY_CURRENT_USER\Software\Microsoft\SQL Server Management Studio\11.0\FileExtensionMapping\PRC] I changed the Default key value to {B5A506EB-11BE-4782-9A18-21265C2CA0B4}.

On [HKEY_CURRENT_USER\Software\Microsoft\SQL Server Management Studio\11.0\Default Editors\PRC] I changed the Custom key value to {B5A506EB-11BE-4782-9A18-21265C2CA0B4}.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.