Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

I'm trying to use data pump to move the database to a different server with this command:

impdp dbuser/dbpsw@dbserver directory=data_pump_dir network_link=sourceDB schemas=EMP

But I got this error:

UDI-00018: Data Pump client is incompatible with database version 11.01.00.06.00

The source DB version is:

Oracle Database 11g Enterprise Edition Release 11.1.0.6.0 - 64bit Production PL/SQL Release 11.1.0.6.0 - Production
CORE 11.1.0.6.0 Production
TNS for 64-bit Windows: Version 11.1.0.6.0 - Production
NLSRTL Version 11.1.0.6.0 - Production

The target DB version is:

Oracle Database 11g Release 11.2.0.2.0 - 64bit Production
PL/SQL Release 11.2.0.2.0 - Production
CORE 11.2.0.2.0 Production
TNS for Linux: Version 11.2.0.2.0 - Production
NLSRTL Version 11.2.0.2.0 - Production

Does it mean I need to upgrade source DB version to be same as target DB? If I can't upgrade database on the source DB, can I only upgrade the impdp utility? If yes, how?

Thank you for your time.

share|improve this question

migrated from stackoverflow.com Feb 27 at 14:54

This question came from our site for professional and enthusiast programmers.

    
your target db is "dbserver". What is the version of your impdp utility. Are you starting impdp on the server were "dbserver" is running. Is it the impdp from the "dbserver" ORACLE_HOME? –  miracle173 May 2 at 14:09

1 Answer 1

MOS 553337.1 probably holds your answer. The compatibility parameter of each database can affect data pump.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.